Blog

Post tecnico: Yii2, come risolvere un problema di aggiornamento del pacchetto yii2soft\yii2-swiftmailer alla versione 2.1.0

Valutazione attuale: 0 / 5

Stella inattivaStella inattivaStella inattivaStella inattivaStella inattiva
 

Recentemente ho fatto un aggiornamento dei pacchetti di una applicazione sviluppata con Yii2. Per farlo ho usato il classico comando > composer update.

L'applicazione prevede la possibilità di spedire messaggi di posta elettronica tramite appositi bottoni. Dopo l'aggiornamento, mi sono reso conto che l'invio non avveniva più, al contrario di altre applicazioni simili che non erano state aggiornate. La causa era quindi molto probabilmente dovuta all'aggiornamento del pacchetto yii2soft\yii2-swiftmailer alla versione 2.1.0.
La nuova versione introduce infatti un importante aggiornamento rendendo il pacchetto compatibile con SwiftMailer 6.0.x, che purtroppo sul mio software non funziona. Cercando il problema specifico non ho trovato purtroppo alcuna soluzione. Allora ho pensato che avrei potuto semplicemente reinstallare la vecchia versione 2.0.7 che funzionava perfettamente.

Per fare il downgrade mi ha di nuovo aiutato il magico "composer":

edito il composer.json alla riga

"yiisoft/yii2-swiftmailer": "*",

la modifico in

"yiisoft/yii2-swiftmailer": "=2.0.7",

con il comando >composer update e in un attimo riporto il pacchetto alla versione funzionante.
I messaggi di posta elettronica ora vengono spediti correttamente.

Naturalmente è possibile tramite gli stessi comandi fare il downgrade e riportare qualsiasi pacchetto alla versione più compatibile con le nostre esigenze.

Questa è la soluzione che ho trovato e che condivido volentieri. Se avete avuto lo stesso problema e siete riusciti a risolverlo in altro modo, lasciate un commento. Sarà molto utile e apprezzato. Grazie.

 

0
0
0
s2sdefault

Cosa posso fare per te?

Contattami, ti presenterò la mia attività e quello che posso fare per aiutare la tua azienda.

In questo sito vengono utilizzati cookie tecnici e di terze parti per migliorare la vostra esperienza di navigazione.

Proseguendo nella navigazione ci consenti di utilzzare i cookie. Per saperne di piu'

Approvo
©2017 SoftRiz. Tutti i diritti riservati - P.IVA 01313090191